HTC One X Forum

HTC One X => HTC One X Help Desk. => : bachje November 08, 2011, 01:27:01 PM



: HTC One XE - Mute on answer?
: bachje November 08, 2011, 01:27:01 PM
Hi to all who is reading this. This is my first post on this forum.
Sorry for my bad English.
I own HTC One XE for about two weeks and I love this phone. Owned HTC Desire HD before One.

But there is a problem with my One XE, it happens 8 out of 10 times. When someone calls me, I pick up (green sign drag into circle) the person who called me can't hear me for about 5 seconds but I hear the caller right away.
Has anyone had this kind of situation?
Thanks.


: Re: HTC One XE - Mute on answer?
: AdderW November 08, 2011, 02:09:33 PM
Most likely a hardware problem ... maybe

How are you holding the phone?
note that the microphone is located at the bottom of the phone,
are you blocking it ? is the hole clogged ? do you have a skin on the phone ? does it have a hole for the mic?


In settings, change the band from Automatic to GSM.


: Re: HTC One XE - Mute on answer?
: bachje November 08, 2011, 02:33:36 PM
Hi. Thanks for your reply...
When I hold the phone I am not blocking the microphone. I do have a case for One but it has a hole for the microphone so the microphone is not blocked.
When I change the band to GSM that thing does not happens, I am able to hear caller right away, no problem. But what is the point of the smartphone if I have to use only GSM.

What do you think is it a hardware or software issue? Should I take it to the service?

Thanks.

And one more thing... The thing that I can't hear person who is calling me happens when I am at work, but for example when I am at home I try to call my self from another phone and the microphone is activated right away when I pick up (no mute). I try that about 100 times and always works perfect (band is set to automatic)

Thanks.


: Re: HTC One XE - Mute on answer?
: AdderW November 08, 2011, 02:48:03 PM
When I change the band to GSM that thing does not happens, I am able to hear caller right away, no problem.

Very interesting. Most likely a software problem, then. :)


: Re: HTC One XE - Mute on answer?
: bachje November 08, 2011, 03:07:46 PM
I hope that is software issue  :)
If I have to take to the service I am without the phone for at least 1 month, maybe more. I think I will wait for official Ice Cream to be realased or maybe some update will fix issue.
Anyway, if I find out something new regarding this problem, I will post that here.


: Re: HTC One XE - Mute on answer?
: CoreISP November 08, 2011, 03:48:40 PM
It could be a flaw in your UMTS antenna.
You could also ask your provider if there are known issues on their UMTS network.

You can of course check if it is a software problem by considering a full factory reset or install a different rom. The latter can void warranty though so... Be careful :P


: Re: HTC One XE - Mute on answer?
: bachje November 08, 2011, 04:47:31 PM
Hi! Thanks.
Already made factory reset - same thing happens, I am considering to put some custom rom to try that solution but than on the other hand, like you said, the warranty...
So I am still considering...

What do you think, could it be my SIM card maybe?


: Re: HTC One XE - Mute on answer?
: CoreISP November 08, 2011, 07:35:54 PM
I kind of doubt it, you seem to get access to the network just fine...


: Re: HTC One XE - Mute on answer?
: bachje November 11, 2011, 04:30:23 AM
It is not sim card problem. Borrowed from a friend, still the same thing - you were right.
But I google it those 3,4 days. Find bunch of people who is having exactly the same problem with Gingerbread 2.3.4 and Sense 3.0.

I hope that some future update will fix it and hope get this update as soon as posible.


: Re: HTC One XE - Mute on answer?
: CoreISP November 13, 2011, 08:14:14 AM
Well, you could consider doing a Full Factory reset in the hope that this changes it.
Simply take a backup with Easy Backup (Do !NOT! backup System Settings!) and download SMS & Contacts backuper for those. (If you do not store to gmail account)

If that does not help, can you post your software version?
This can help indicate whether it is a soft- or hardware problem. I hope it is just software :) I personally hate returning phones to warranty.


: Re: HTC One XE - Mute on answer?
: bachje November 13, 2011, 04:38:26 PM
Thanks for reply... And for trying to help.
I tried already factory reset, that did not helped me :( I am considering of flashing it with Stock ROM so I don't lose warranty.

There is nothing worse than sending a phone to the service, I couldn't agree with you more on that. I just hope that original Stock ROM maybe would work or maybe OTA update comes in a week or two :)

I am going insane with that my phone :-X. If nothing happens (OTA or original Stock ROM) I would have to take it to the service.


: Re: HTC One XE - Mute on answer?
: CoreISP November 13, 2011, 08:46:41 PM
To flash a rom you still need to make modifications to the core software that will void your warranty. Running the stock rom is not the only thing for warranty.

If the bootloader is S-OFF they will screw you over.


: Re: HTC One XE - Mute on answer?
: bachje November 14, 2011, 05:29:56 AM
Tried Stock ROM, 2 versions... Still the same thing!?
Finally I called my Service store in Croatia, described my problem and they told me that everything is ok with my phone, that is network issue, that few others have complained about the same problem. It is just that some phone numbers get "stuck" when calling me and therefore is delay for 5 seconds...

I am not sure that is normal and they are right?

Any thoughts?
Thanks.


: Re: HTC One XE - Mute on answer?
: CoreISP November 14, 2011, 07:35:39 AM
I have never heard of that before and it sounds like the BS factor is very high in this one, but experience learns us that the HTC customer service rather er... Sucks. Cant find a better word to describe their high rate of incompetence.


: Re: HTC One XE - Mute on answer?
: bachje November 14, 2011, 03:43:44 PM
Couldn't agree with you more...

My English is not perfect but I manage to understand with people :)
My German Language is the same as English. I posted few questions about my problem on Germans forums as well.

No one heard about same problem. Usually I find on Forums what I need (I am working as IT ingeneer), but for this issue no help 8)

unbelievably :)


: Re: HTC One XE - Mute on answer?
: bachje November 16, 2011, 07:58:57 AM
Hi again!
I have been doing so much investigating my problem on my own (did not take phone to the service)

I am going insane.
Here is what's happening:
I bought myself new prepaid number and simcard from one other mobile carrier here in Croatia, put it in my One and everything worked perfect! Ok. So I thought maybe changing my SIM card from my carrier (T-Mobile) would fix things.
I went to the store and they gave me brand new SIM with my phone number. I put it in my One and the problem was again there!!!!

So as a conclusion: Everything is all right with the phone obviously (it works on other mobile network without problems), but when I am on my network (T-Mobile) regardless which T-Mobile SIM card inserted (tried 4) the problem is there!?!?!?!

So I would appreciate any help.

Thanks to all.


: Re: HTC One XE - Mute on answer?
: AdderW November 16, 2011, 08:10:31 AM
Do a test with some headphones that has an inbuilt microphone, if that works then you most probably
have a hardware problem, i.e. the built in microphone.

Have a look at the "Call Delay Patch" by BYTEWORKS.CZ in the Market.



: Re: HTC One XE - Mute on answer?
: bachje November 16, 2011, 08:52:46 AM
Thanks...
I agree it could be a microphone, but how come that everything is working great on the other network (VIP) but just on mine (T-Mobile) I have this problem? If it is a mic issue than it would be a problem on the other network as well? Or I am wrong?

Thanks.


: Re: HTC One XE - Mute on answer?
: bachje November 16, 2011, 06:05:54 PM
Hi...
Tested my One XE with phones thhat came along (Dr. Dre) and same thing happens all the time

 - T-Mobile, regardles which T-Mobile card I put in - problem with incoming calls

 - VIP (other network) - No issue at all

I am going crazy   >:(


: Re: HTC One XE - Mute on answer?
: AdderW November 16, 2011, 06:40:01 PM
Hi...
Tested my One XE with phones thhat came along (Dr. Dre) and same thing happens all the time

 - T-Mobile, regardles which T-Mobile card I put in - problem with incoming calls

 - VIP (other network) - No issue at all

I am going crazy   >:(


Did you try the "Call Delay Patch" app ?

also, have a look at this thread: http://forum.xda-developers.com/showthread.php?t=935250 (http://forum.xda-developers.com/showthread.php?t=935250)

and if you have rooted your phone, please try other kernels


: Re: HTC One XE - Mute on answer?
: bachje November 17, 2011, 02:34:43 AM
I tried Call Delay patch - Not working for me :(

My phone is not rooted. Does Dewonkificator goes only to Rooted phones or I can use it on non Rooted phones as well?

Thanks.


: Re: HTC One XE - Mute on answer?
: bachje November 19, 2011, 11:53:37 AM
Called my carrier and explained my problem, spend all Thursday and Friday on the phone talking to the service of T-mobile and they can see mute problem (on their soetware platforms) but they don't know how to fix it  >:(
It seems that this my phone when registering on network with it' IMEI and some other hardware information has that problem!?
They admit it has been same issue about 3 years ago with one Desire and that man manage to change the phone at HTC for new Desire!?


: Re: HTC One XE - Mute on answer?
: rdamontz November 23, 2011, 02:02:09 AM
hi all,

I had this problem but was able to fix this.  The mic takes about 3 seconds to get started and from time to time you will not be heard by the other party.

I adjusted the volume to full and this problem was gone.


: Re: HTC One XE - Mute on answer?
: CoreISP November 23, 2011, 08:21:14 PM
If that's true then AndroSensor is a great app to diagnose this.
I must say I never seen this issue, the microphone works without any lag at all for me and 3 seconds seems like a rather long waiting time to me. I expect it to work instantly. And thank god it does on my phone :P


: Re: HTC One XE - Mute on answer?
: bachje November 24, 2011, 06:48:08 AM
Hi!
Thanks for trying to help me.
I tried all of these things (volume to max, delay patch, hard reset, soft reset, contacted HTC here in Croatia, HTC Deutschland...)
Same result always.
But I contacted also my carrier (T-mobile) and they really manage to do something :)
My problem has not been solved 100% but from some numbers that this call delay was happening it doesn't happens any more :)
Those guys from T-Mobile Service admitted that is the carrier problem and they put my problem at some higher level (at least they said so). So now I am waiting....

Thank you guys for replying.


: Re: HTC One XE - Mute on answer?
: capscom0227 December 25, 2011, 09:50:15 PM
I think it has something to do with the data connections available where you are. Is there wifi available in your workplace where you have problems (delay with the call)? There is a setting there in the phone where it switches to connection sources. I can't remember what it is but you can check.


: Re: HTC One XE - Mute on answer?
: bachje December 26, 2011, 04:38:27 PM
Well, my data connection is off. This problem happens regardles my wifi or data connection is on or off...


: Re: HTC One XE - Mute on answer?
: Recoil February 22, 2012, 07:30:40 AM
Hi, same problem here & same provider (t-mobile)... Updating firmware, trying different radios didn't help. Microphone is working properly. Any tips? Would really be gratefull for some help or advice.


: Re: HTC One XE - Mute on answer?
: AdderW February 22, 2012, 07:47:54 AM
Hi, same problem here & same provider (t-mobile)... Updating firmware, trying different radios didn't help. Microphone is working properly. Any tips? Would really be gratefull for some help or advice.


Most likely a hardware issue.


: Re: HTC One XE - Mute on answer?
: bachje February 22, 2012, 08:14:08 AM
Hi, same problem here & same provider (t-mobile)... Updating firmware, trying different radios didn't help. Microphone is working properly. Any tips? Would really be gratefull for some help or advice.


Most likely a hardware issue.

Well I would't agree about hardware issue because on every other network (expect mine which is T-Mobile) everything works like a charm :)


Sorry, the copyright must be in the template.
Please notify this forum's administrator that this site is missing the copyright message for SMF so they can rectify the situation. Display of copyright is a legal requirement. For more information on this please visit the Simple Machines website.